Bug #1083

Linux: performances issues, crashes

Added by L D about 1 year ago. Updated 11 months ago.

Status:ClosedStart date:09/27/2017
Priority:NormalDue date:
Assignee:Frédéric Bertolus% Done:

0%

Category:-
Target version:Ongoing issues

Description

Hi!

I have some severe performances troubles sometimes, which usually leads to a game crash. After a moment playing, the game can start to lag heavily. I've noticed that using the "J" key to pass days is often involved in the crashes.
These issues appears when i launch the game via Steam, but also when i launch it with the command line. I've tried also the beta, which seemed to be a bit worse about rendering performances.
Besides this, the game is very dark (i know it's intentional, which is great!) and i need to push the gamma at max. No lights from my ship, since i understood there should be one. And the engine sound is almost always clipping (probably due to the mem being saturated).
I've joined the crashes directories and the savegame, even if i don't think the later is related to the issues.

Here is the output i have in the command line when it crashes (stable version, but the beta one is almost the same):

Pooling OS allocations (pool size: 1408 MB, maximum allocations: 9502).
Using binned2.
4.16.3-0+++UE4+Release-4.16 513 0
Disabling core dumps.
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
LowLevelFatalError [File:/home/fred/s2/workspace/4.11/UnrealEngine/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformMemory.cpp] [Line: 416]
munmap(addr=0x7f2b4cf69000, len=135168, size as passed 65536) failed with errno = 12 (Cannot allocate memory)
Signal 11 caught.
Malloc Size=131076 LargeMemoryPoolOffset=131092
CommonLinuxCrashHandler: Signal=11
Malloc Size=65535 LargeMemoryPoolOffset=196655
Engine crash handling finished; re-raising signal 11 for the default handler. Good bye.
Segmentation fault (core dumped)

And finally, my specs:

Laptop Linux Ubuntu 16.04 (64bits); proc i3-6100H CPU @ 2.70GHz × 4; RAM 4Go
Intel HD Graphics 530 (Skylake GT2); Version OpenGL : 3.0

I hope all this will help you! Et si vous avez besoin, je suis français, donc on peut affiner les choses dans notre langue maternelle!
Good luck!

Crashes.zip (27.6 KB) L D, 09/27/2017 02:30 PM

SaveSlot1.json (4.16 MB) L D, 09/27/2017 02:38 PM

History

#1 Updated by L D about 1 year ago

Any news, guys?

#2 Updated by Gwennaël Arbona about 1 year ago

  • Target version set to Ongoing issues

We don't know for sure but it might be due to not enough memory, which is annoying because 4GB is supposedly enough.

#3 Updated by L D about 1 year ago

Thanks for the answer! That's what i suspected, considering the symptoms... I'll check if i can confirm that on my side.

#4 Updated by L D about 1 year ago

Hi guys,
Any news about that? I've confirmed that the game ate almost all the RAM when runnning, but i guess you already had that clue. So have you found something?
Thanks! Can't wait to hear from you, because i've stopped playing the game for now, too unstable...

#5 Updated by Gwennaël Arbona about 1 year ago

Could you try setting the texture quality to the lowest ? Aside from that, I'm not sure what we can do for now.

#6 Updated by L D about 1 year ago

I just tried quickly (launch the game, load a save, fly a bit around) with all the graphic settings off or lowest. No real luck, apparently, it still lag a bit. I'll have to test it in the long term, though, and i'll keep you in touch with this.
But i must say that previously, my graphic settings were already at the lowest, appart from the texture one which was medium. I had the AA thingy on too (the second button, not the 2x), and the antialiasing, i think. I had the cracking sound again, by the way; i'm no expert, but i think that linux sound server can be a bit tricky sometimes, maybe it's a lead.
Anyway, thanks for the answer, i hope the next builds will help with this somehow...

#7 Updated by Gwennaël Arbona about 1 year ago

  • Assignee set to Frédéric Bertolus

#8 Updated by Gwennaël Arbona 11 months ago

  • Status changed from New to Closed

Also available in: Atom PDF