Bug #1130

[Linux] Can't click on controls not in the top menu bar

Added by Alexander Brüning 9 months ago. Updated 5 months ago.

Status:ClosedStart date:01/05/2018
Priority:HighDue date:
Assignee:Gwennaël Arbona% Done:

0%

Category:-
Target version:Final update

Description

On the current stable and beta version, I can't use any control widget below the top menu bar (see screenshot). I can access the settings menu, but only spin the box around.

CrashReportClient.ini Magnifier (108 Bytes) Alexander Brüning, 01/05/2018 04:50 PM

Diagnostics.txt Magnifier (5.81 KB) Alexander Brüning, 01/05/2018 04:50 PM

2018-01-05-164254_1920x1080_scrot.jpg (379 KB) Alexander Brüning, 01/05/2018 04:50 PM

steam-sysinfo.txt Magnifier (1.98 KB) Alexander Brüning, 01/05/2018 04:52 PM

CrashContext.runtime-xml (3.04 KB) Alexander Brüning, 04/26/2018 07:39 PM

CrashReportClient.ini Magnifier (108 Bytes) Alexander Brüning, 04/26/2018 07:39 PM

Diagnostics.txt Magnifier (4.96 KB) Alexander Brüning, 04/26/2018 07:39 PM

minidump.dmp (4 Bytes) Alexander Brüning, 04/26/2018 07:39 PM

steamoutput.txt Magnifier (55.7 KB) Alexander Brüning, 04/26/2018 08:23 PM

410

History

#1 Updated by Gwennaël Arbona 9 months ago

  • Assignee set to Frédéric Bertolus
  • Target version set to Ongoing issues

#2 Updated by Alexander Brüning 8 months ago

I can reproduce it on the 2018-01-25 version as well.

#3 Updated by Gwennaël Arbona 8 months ago

That's unfortunate. We'll try to find some time to get a Funtoo/Gentoo running, but for the time being we're focusing on mainstream distros, since we can't realistically test them all anyway.

Since this is a game breaking bug that we don't know how to fix yet, don't hesitate to ask for a Steam refund.

#4 Updated by Gwennaël Arbona 7 months ago

Hi, can you try with the updated Beta channel for the game on Steam ?

#5 Updated by Alexander Brüning 7 months ago

Gwennaël Arbona wrote:

Hi, can you try with the updated Beta channel for the game on Steam ?

Just tried it, same issue :/

I'd gladly help you with debugging/setting up a testing machine when you have the time.

#6 Updated by Gwennaël Arbona 7 months ago

Okay. We'll let you know when we can get some time on this.

#7 Updated by Gwennaël Arbona 5 months ago

  • Subject changed from Can't click on controls not in the top menu bar to [Linux] Can't click on controls not in the top menu bar
  • Status changed from New to Waiting feedback
  • Assignee changed from Frédéric Bertolus to Alexander Brüning
  • Priority changed from Normal to High

Hi Alexander,

We're back on this issue with a special test build. Could you try the following procedure to help us track down the issue ?
- In Steam,right-click the game, pick Properties
- In the Betas tab, enter "heliumraindebug" as an access code, this should enable the "ui-debug" branch of the game
- This branch is exactly like the current game, with a twist : once you've clicked somewhere it will start logging debugging data to the screen
- Please put the mouse in the blank area where buttons don't work, and get us a screenshot of the output.

This is a pretty annoying issue to track down, so we're trying to get as much information as possible.

Thank you for helping us with the game.

#8 Updated by Alexander Brüning 5 months ago

Gwennaël Arbona wrote:

This is a pretty annoying issue to track down

I hate to be the bearer of bad news, but the debug build doesn't start, crashes after briefly showing the loading screen. Beta and regular are fine. I have

  • Verified my game files
  • Deleted the config folder
  • Tried it with a fresh config folder from the beta

:/

#9 Updated by Gwennaël Arbona 5 months ago

Uh, could you try again right now ? Restart the Steam client to ensure the game is updated.

#10 Updated by Alexander Brüning 5 months ago

Gwennaël Arbona wrote:

Uh, could you try again right now ? Restart the Steam client to ensure the game is updated.

This version crashes slower and doesn't seem to create a config dir or crash information files. I have attached what's being printed on the terminal I launched Steam from, though, I think it gets interesting from line 682 on:

[2018.04.26-18.19.24:514][  1]LogFlare: Display: AFlarePlayerController::PlayerTick : New mouse cursor state is 1
[2018.04.26-18.19.25:303][  1]LogLinux: Error: appError called: Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:Runtime/Core/Public\Containers/Array.h] [Line: 610] 
Array index out of bounds: -1 from an array of size 0

CommonLinuxCrashHandler: Signal=11
[2018.04.26-18.19.25:878][  1]LogLinux: === Critical error: ===
Unhandled Exception: SIGSEGV: invalid attempt to write memory at address 0x0000000000000003

[2018.04.26-18.19.25:878][  1]LogLinux: Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:Runtime/Core/Public\Containers/Array.h] [Line: 610] 
Array index out of bounds: -1 from an array of size 0

#11 Updated by Alexander Brüning 5 months ago

(By slower I mean that it takes a bit longer to fully quit, it doesn't get any further than the last one)

#12 Updated by Gwennaël Arbona 5 months ago

Thanks, I've updated the debug build to narrow it down. Can you try again ? As with the previous test, be sure to restart Steam to trigger the update.

I apologize for sending you experimental builds to try out this way. I'd much rather release an update right away, but this issue is a real piece of work.

#13 Updated by Alexander Brüning 5 months ago

Gwennaël Arbona wrote:

I apologize for sending you experimental builds to try out this way. I'd much rather release an update right away, but this issue is a real piece of work.

No problem. This one starts and prints the debug stuff. It says Pointed = , focus = SViewport when loading up, clicking on the non-functioning UI elements or when I mess with the locker/door thing in the settings, and Pointed = , focus = SButton when interacting with the buttons in the top right corner.

#14 Updated by Gwennaël Arbona 5 months ago

  • Status changed from Waiting feedback to In Progress
  • Assignee changed from Alexander Brüning to Gwennaël Arbona

Great. Thanks a lot for helping us on this. We'll get back to you when we have a fix.

#15 Updated by Gwennaël Arbona 5 months ago

Actually, I might have something to try out right now. Can you restart Steam and test the game after the update ? Is the UI still unresponsive now ?

#16 Updated by Alexander Brüning 5 months ago

Gwennaël Arbona wrote:

Actually, I might have something to try out right now. Can you restart Steam and test the game after the update ? Is the UI still unresponsive now ?

Downloaded it, behaves the same though.

#17 Updated by Gwennaël Arbona 5 months ago

Too bad. I'll get back to you.

#18 Updated by Gwennaël Arbona 5 months ago

Okay, here's a last attempt for today to confirm where the issue might be. This build still displays logs and also breaks parts of the user interface on purpose ; the menu bar on top shouldn't work. I'm curious as to whether the main interface elements do work now, including the save slot buttons.

As usual, please restart Steam to force updating.

#19 Updated by Alexander Brüning 5 months ago

Gwennaël Arbona wrote:

This build still displays logs and also breaks parts of the user interface on purpose ; the menu bar on top shouldn't work. I'm curious as to whether the main interface elements do work now, including the save slot buttons.

That's exactly what's happening for me with this build, top bar is broken, everything else seems to work.

#20 Updated by Gwennaël Arbona 5 months ago

Thanks, we're making great progress now. The issue is in our code, and is apparently triggered by a different DPI handling on your platform. I could reproduce the issue by breaking the part that usually works and I'll get back to you with a build that hopefully fixes things.

#21 Updated by Gwennaël Arbona 5 months ago

Alexander, I've just updated the test branch again. Could you have a look ?

#22 Updated by Alexander Brüning 5 months ago

Gwennaël Arbona wrote:

Alexander, I've just updated the test branch again. Could you have a look ?

This seems to have done the trick! Things I've tested:

  • Create and delete new game
  • Change graphics and gameplay settings
  • Gameplay until after doing the first contract tutorial
  • Exiting the game

Thank you!

#23 Updated by Gwennaël Arbona 5 months ago

  • Status changed from In Progress to Resolved

That's great to hear. So sorry it took so long for us to get to it :(

I've updated the main branch for the game with the same build you received, and will remove this specific debugging branch very soon. Make sure to opt out of the beta !

#24 Updated by Gwennaël Arbona 5 months ago

  • Status changed from Resolved to Closed
  • Target version changed from Ongoing issues to Final update

Also available in: Atom PDF