Bug #1131

crash on steam link

Added by Josh Sumoski 9 months ago. Updated 3 months ago.

Status:ClosedStart date:01/06/2018
Priority:HighDue date:
Assignee:Gwennaël Arbona% Done:

0%

Category:-
Target version:Final update

Description

using the beta with -vulkan option on ubuntu 17.10 with nvidia 384.90 drivers. (without vulkan, the game results in a green screen on the steam link...this is a known issue with UE4 games on linux). The game runs on the host machine. When launching through the steam link, it launches, but when loading a saved game, it locks up and then crashes after a couple of seconds.

minidump.dmp (4 Bytes) Josh Sumoski, 01/06/2018 12:59 AM

crashinfo-HeliumRain-pid-3192-015606301C010905003700F9641C232D.zip (3.97 KB) Josh Sumoski, 01/06/2018 03:47 PM

History

#1 Updated by Frédéric Bertolus 9 months ago

  • Assignee set to Frédéric Bertolus
  • Priority changed from Normal to High

Oh, sorry, can you also attach the Diagnostics.txt file (on Linux le minidump.dump is empty but the stacktrace is visible in the Diagnostic.txt). You can also zip the while directory and attach it.

Thanks !

#3 Updated by Josh Sumoski 8 months ago

I can confirm that this is still happening with the latest nvidia driver update (384.111)

#4 Updated by Gwennaël Arbona 8 months ago

  • Target version set to 17

Thank you for the report. At the moment we don't support Steam Link ; we'll see with future engine updates if that gets better.

#5 Updated by Josh Sumoski 8 months ago

thats fair, but the steam link is only a device to basically mirror the desktop, as far as I know there is nothing different that needs to be done for it. I'm aware of the green screen issue (I think valve are the ones working on it). With vulkan, it works, but locks up and crashes immediately. If I use vulkan on the desktop, it works for a little while but eventually (~5-10 minutes) locks up and crashes. Since its the same basic issue with vulkan, just at different times (immediate vs. delayed), it could be either an issue with multiple monitor/mirroring, or a memory leak (since mirroring the screen will use more resources).

#6 Updated by Gwennaël Arbona 6 months ago

  • Status changed from New to Closed
  • Assignee changed from Frédéric Bertolus to Gwennaël Arbona

We've seen people have better success with Steam Link and newer engine versions. We don't officially support this hardware, or test with it - we hope the Unreal Engine will be working correctly with it in the future.

#7 Updated by Michael P 6 months ago

Gwennaël Arbona wrote:

We've seen people have better success with Steam Link and newer engine versions. We don't officially support this hardware, or test with it - we hope the Unreal Engine will be working correctly with it in the future.

This isn't a steam-link only issue. Its reproducible just with steam streaming from PC to PC via the steam client, no hardware required, except two computers: one as the host streaming and the other as the client.

#8 Updated by Michael P 6 months ago

Gwennaël Arbona wrote:

We've seen people have better success with Steam Link and newer engine versions. We don't officially support this hardware, or test with it - we hope the Unreal Engine will be working correctly with it in the future.

This isn't a steam-link only issue. Its reproducible just with steam streaming from PC to PC via the steam client, no hardware required, except two computers: one as the host streaming and the other as the client. Please re-open this defect and help Valve? They don't seem to want to prioritize this... https://github.com/ValveSoftware/steam-for-linux/issues/5337

#9 Updated by Gwennaël Arbona 3 months ago

  • Target version changed from 17 to Final update

Also available in: Atom PDF