Bug #1141

"Fire weapon" binding is misleadingly blank by default

Added by zx64    ⠀ 9 months ago. Updated 9 months ago.

Status:ClosedStart date:01/26/2018
Priority:NormalDue date:
Assignee:Gwennaël Arbona% Done:

0%

Category:-
Target version:Ongoing issues

Description

Version tested: 2018-01-25

This is related to #1139 and figured it was better to split this off into a separate issue.

Up until this release, I'd avoided the combat side of the game so hadn't really paid attention to the binds etc. for that part of the game.
In preparation for jumping into skirmish I checked my binds and was confused by the fire weapons button being unbound.
Additionally when I tried to bind fire weapons to left mouse button, the menu didn't accept that as a valid input choice, which was also confusing.

After trying some inputs in skirmish I realised that things were ok, I just had to switch to a turret and left mouse button was already set up to fire.
This confusion is also how I ran into #1138 as I thought I had to toggle weapons before I could fire them.

It's possible that had I played the combat tutorials ahead of time I wouldn't have been confused by this (tie in with #1139), but hopefully me telling you some specific aspects where I got confused by the UI will help next time you do a pass on UI/input etc.

History

#1 Updated by Gwennaël Arbona 9 months ago

  • Assignee set to Gwennaël Arbona
  • Target version set to Ongoing issues

#2 Updated by Gwennaël Arbona 9 months ago

  • Status changed from New to Closed

There is a small hint text at the top of the control settings panel to tell the user of this !

Also available in: Atom PDF