Bug #1161

Green screen when streaming or using Steam-link

Added by Michael P 6 months ago. Updated 6 months ago.

Status:ClosedStart date:04/11/2018
Priority:HighDue date:
Assignee:Gwennaël Arbona% Done:

0%

Category:-
Target version:Ongoing issues

Description

Your system information
CPU: Intel i7-8700k
Video: Nvidia Geforce 1080 TI (using v390.48)
RAM: 64 GB
Steam client version (build number or date): Apr. 4 2018
Distribution (e.g. Ubuntu): Fedora 26
Opted into Steam client beta?: No, but would if a fix were to come along
Have you checked for system updates?: Yes
Please describe your issue in as much detail as possible:
http://steamcommunity.com/app/353380/discussions/0/1488866180617424880/

There seems to be an issue with steam streaming Unreal Engine 4 based games. When streaming to steam link or another computer with steam, the game will load but only shows a green / black screen. You can hear audio and can move the mouse which will interact with the menu, so the game isn't frozen. I have tested this on two games, but others are also reporting the same findings on two other games, one of which is not supported on Linux just yet; therefore, it could be a Windows and Linux issue.

If you install the games locally, not streaming, they work just fine.

Known games with this problem: Helium Rain, Stellar Overload, Everspace, and Interstellar Cat

Steps for reproducing this issue:
Stream a UE4 based game (known games are Helium Rain, Stellar Overload, Everspace, and Interstellar Cat)

Valve is aware of this issue, but they aren't prioritizing it. Well, they aren't discussing its priority and therefore for the last 5 months or so, I haven't been able to play your game! I purchased your game, discovered this issue, got a refund, saw the game on-sale 30% off, bought it, re-discovered the issue, and now simply waiting! its frustrating to say the least. I really don't want to steam refund your game anymore, please work with Steam and Epic to resolve this issue.

HR_pc-pc_streaming_log_green_screen.txt Magnifier (5.43 KB) Michael P, 04/11/2018 07:43 PM

HR_steamlink_streaming_log_green_screen.txt Magnifier (14.9 KB) Michael P, 04/11/2018 07:43 PM

PoE_pc-pc_streaming_log_works.txt Magnifier (6.63 KB) Michael P, 04/11/2018 07:43 PM

PoE_steamlink_streaming_log_works.txt Magnifier (26.9 KB) Michael P, 04/11/2018 07:43 PM

Screenshot from 2018-04-11 09-25-46.png (10.4 KB) Michael P, 04/11/2018 07:45 PM

Screenshot from 2018-04-11 10-48-21.png (743 KB) Michael P, 04/11/2018 07:48 PM

447
448

History

#1 Updated by Gwennaël Arbona 6 months ago

  • Status changed from New to Waiting feedback
  • Assignee changed from Gwennaël Arbona to Michael P
  • Target version set to Ongoing issues

Hi, we're aware on this issue already. As you point out, this is a well-known issue on Valve's side but Steam Link appears to not be a priority for them anymore.

Can you try launching the game with the -vulkan command-line parameter ? We only suggest that for Linux users, but it could have an effect and it's pretty much the extent of options we have for now.

#2 Updated by Michael P 6 months ago

Gwennaël Arbona wrote:

Hi, we're aware on this issue already. As you point out, this is a well-known issue on Valve's side but Steam Link appears to not be a priority for them anymore.

Can you try launching the game with the -vulkan command-line parameter ? We only suggest that for Linux users, but it could have an effect and it's pretty much the extent of options we have for now.

Just to be clear, this is not only a steam-link issue. You do not need steam-link to reproduce. This is related to steam streaming and can be reproduced without the steam-link; all you need is two PCs with steam, one to be the streaming host, and the other to be the stream client. Presumably on Linux and Nvidia hardware seeing as that is what I have and can reproduce.

In regards to '-vulkan', this does not work for me. I have enabled the beta branch and tested both '%command% -vulkan' and '-vulkan' in the launch settings, but the game freezes during load; no music and no audible feedback that controls work. At least with OpenGL (default), Helium Rain loads. I just can't see the screen because its green, but I can hear the music and get audible feedback that controls work.

#3 Updated by Michael P 6 months ago

Uploading logs for analysis and screenshot to prove this green screen issue isn't just a steamlink or hardware issue. It happens also via streaming PC-to-PC

#4 Updated by Michael P 6 months ago

I have provided all the information I can... it would be nice if this was reassigned to someone on the team that could look into it instead of being idle.

#5 Updated by Gwennaël Arbona 6 months ago

  • Status changed from Waiting feedback to In Progress
  • Assignee changed from Michael P to Gwennaël Arbona

Hello Michael !

As I said last time, this is unfortunately not an issue on the game side. Streaming the game works fine on Windows using OBS or Shadowplay, and we also streamed on Linux in the past, using OBS. To be clear, streaming isn't an engine feature - game streaming works by simply grabbing the output of the game, something the streaming software is responsible for. There is no streaming-specific code in the engine or the game, so there is no code that we could fix on our side. The reason I suggested Vulkan is that it might be a very different output method that works best with Steam Link, but it obviously requires drivers that support it well.

We're not ignoring the issue - we did get in touch with Unreal Engine developers to confirm the problem isn't on the engine side. We're still waiting on their feedback for now, but we'll be sure to update you when we know more. In the meantime, you could try using something like OBS in combination with a remote input software, even though it's not as practical as Steam Link.

#6 Updated by Michael P 6 months ago

Gwennaël Arbona wrote:

Hello Michael !

We're not ignoring the issue - we did get in touch with Unreal Engine developers to confirm the problem isn't on the engine side. We're still waiting on their feedback for now, but we'll be sure to update you when we know more. In the meantime, you could try using something like OBS in combination with a remote input software, even though it's not as practical as Steam Link.

I didn't mean to indicate the defect was being ignored, only that it was assigned to me as 'waiting feedback' and despite 10 days passing of me providing feedback it hadn't changed status and nor could I change the status.

I don't have OBS, and while it may work with OBS, I won't be using OBS. The details I have provided were simply to let you and your team know that this is not a steam-link hardware bound issue and can be reproduced with nothing but steam. Given your game runs on Steam and is supported on the Steam platform, I figured you'd help the issue along. It seems you have reached out to Epic which is about as much as can be expected given it wasn't a specific game issue and more an engine / streaming problem.

Thank you... here's hoping we get some resolution soon, but its already been 6 months... :-(

#7 Updated by Gwennaël Arbona 6 months ago

I understand the annoyance. I hope to have feedback from Epic on this topic soon, but like I explained earlier, the technical problem is very likely to be on Steam's side here. If something like OBS can indeed stream the game, there is no reason Steam can't.

#8 Updated by Michael P 6 months ago

Looks like someone kicked Valve into high gear ;-)

This has been fixed: https://steamcommunity.com/groups/SteamClientBeta#announcements/detail/1657765111819118193

I have verified it works on Steam Link and PC-To-PC in-home streaming

#9 Updated by Gwennaël Arbona 6 months ago

  • Status changed from In Progress to Closed

Great to hear !

Also available in: Atom PDF