Bug #1222

Crash on fast travel

Added by Rémi Robinet about 1 month ago. Updated 30 days ago.

Status:NewStart date:10/17/2018
Priority:NormalDue date:
Assignee:Frédéric Bertolus% Done:

0%

Category:-
Target version:Ongoing issues

Description

Hi guys !
Here is a little issue I encountered tonight.

As soon as I try to fast travel or skip a day (with 'J' or the buttons in the F3 map menu) , the game crashes. I attach a little screenshot of the error message.

Some kind of a scenario about what I did before the first crash occured :

  • Save was working well yesterday.
  • Load game tonight.
  • Check for new contracts.
  • Research Level 3 Tech 'Orbital Pumps' for the Pendulum quest.
  • Undock from shipyard in Blue Heart.
  • Plot course to another sector.
  • Fast travel ... crash :(

I tried to change destination to another sector or come back into starting sector, still crashing. Same after a Steam/Computer reboot.
I updated my graphic drivers to the latest version (nVidia 416.34), still crashing.

I also tried to start a new game on second save slot, no problem at all, fast travel is working well.

Feel free to ask if you need more infos :)

Thank you !

crash1.png (17.4 KB) Rémi Robinet, 10/17/2018 10:01 PM

SaveSlot1.json.gz (170 KB) Rémi Robinet, 10/17/2018 10:11 PM

Crashes_dumps.rar (91.9 KB) Rémi Robinet, 10/17/2018 10:13 PM

SaveSlot2.json.gz - Fixed save (167 KB) Frédéric Bertolus, 10/18/2018 12:08 AM

Combat_Game_log.zip (58 KB) Rémi Robinet, 10/18/2018 06:12 PM

481

History

#1 Updated by Gwennaël Arbona about 1 month ago

  • Assignee set to Gwennaël Arbona
  • Target version set to 1.2.0

Thank you for your report. We'll investigate.

#2 Updated by Gwennaël Arbona about 1 month ago

  • Assignee changed from Gwennaël Arbona to Frédéric Bertolus

Tracked down to AITradeSources::GenerateCache which calls a method on a NULL map entry.

#3 Updated by Frédéric Bertolus about 1 month ago

Hello,

The bug is very strange. A station is lost without sector and this should not happen.

Can you send me the following files from your save directory ?

Combat-7BAF601C4AE95E5F0394B6AC8F39A5D4.log
Game-7BAF601C4AE95E5F0394B6AC8F39A5D4.log

It could be very helpful !

I also attached the save with the station removed (an outpost from AXS, not critical) so it won't crash anymore and you will be able to continue your game.

Thanks !

#4 Updated by Rémi Robinet about 1 month ago

Hello,

Thank you for your quick answer, the new save is working well, thanks a lot !
I attach the files you requested, hope they'll be helpful for fixing.

#5 Updated by Frédéric Bertolus 30 days ago

The station AXSOUT-Margaret-Avant-poste in Tranquillity has been replaced by AXSOUT-Ljiraq-Avant-poste in the liste of stations in tranquility.

So AXSOUT-Margaret-Avant-poste is nowhere and AXSOUT-Ljiraq-Avant-poste is at 2 places at same time. This is the cause of the crash.

Now, after investigation, I have no idea about why there is such data corruption.

#6 Updated by Gwennaël Arbona 30 days ago

  • Target version changed from 1.2.0 to Ongoing issues

Also available in: Atom PDF