Bug #1224

Autopilot Does not Disengage With User Input.

Added by Jacob Triffo 3 months ago. Updated 3 months ago.

Status:ClosedStart date:10/20/2018
Priority:NormalDue date:
Assignee:Gwennaël Arbona% Done:

0%

Category:-
Target version:1.2.1

Description

Autopilot notifies you that using manual controls will abort docking, but using manual controls does not abort docking nor does the ship respond to manual controls at all.

In order to disengage autopilot you have to manually press the mapped key.

History

#1 Updated by Gwennaël Arbona 3 months ago

  • Assignee set to Jacob Triffo
  • Target version set to Ongoing issues

Which keys have you tried ? This is working well here, any thrust key (WSAD etc) terminates the autopilot.

#2 Updated by Jacob Triffo 3 months ago

I'm using a HOTAS setup currently, so I've tried joystick inputs and they seem to be ignored.

Knowing how it works so far, it seems that the joystick is a mouse effectively, and likely joystick commands are being ignored because mouse inputs are being ignored.

#3 Updated by Gwennaël Arbona 3 months ago

  • Assignee changed from Jacob Triffo to Gwennaël Arbona
  • Priority changed from Low to Normal
  • Target version changed from Ongoing issues to 1.2.1

Okay, I will investigate. Thank you for your patience.

#4 Updated by Gwennaël Arbona 3 months ago

  • Status changed from New to Closed

This issue will be fixed with patched 1.2.1.

Also available in: Atom PDF